1065 A+B and C (64bit) (20分)
Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.
Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line Case #X: true
if A+B>C, or Case #X: false
otherwise, where X is the case number (starting from 1).
Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
参考柳神:https://www.liuchuo.net/archives/2023
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
int n,count=0;
long long a,b,c;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%lld %lld %lld",&a,&b,&c);
count++;
long long sum=a+b;
if(a>0&&b>0&&sum<0)
printf("Case #%d: true\n",count);
else if(a<0&&b<0&&sum>=0)
printf("Case #%d: false\n",count);
else if(sum>c)
printf("Case #%d: true\n",count);
else
printf("Case #%d: false\n",count);
}
return 0;
}