公牛和母牛

公牛和母牛

Language:
Bull Math
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16656 Accepted: 8491
Description

Bulls are so much better at math than the cows. They can multiply huge integers together and get perfectly precise answers … or so they say. Farmer John wonders if their answers are correct. Help him check the bulls’ answers. Read in two positive integers (no more than 40 digits each) and compute their product. Output it as a normal number (with no extra leading zeros).

FJ asks that you do this yourself; don’t use a special library function for the multiplication.
Input

  • Lines 1…2: Each line contains a single decimal number.
    Output

  • Line 1: The exact product of the two input lines
    Sample Input

11111111111111
1111111111
Sample Output

12345679011110987654321
Source

USACO 2004 November


代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int MAXLEN = 300;

char * multiply(char *m1,char *m2)
{
	int len1=strlen(m1);
	int len2=strlen(m2);
	int len=len1+len2;
	char *prod=new char[len*sizeof(char)];
	int a[MAXLEN];
	int b[MAXLEN];
	int c[MAXLEN];
	memset(a,0,sizeof(a));
	memset(b,0,sizeof(b));
	memset(c,0,sizeof(c));
	for(int i=0;i<len1;i++)
	{
		a[i]=m1[len1-i-1]-'0';
	}
	for(int i=0;i<len2;i++)
	{
		b[i]=m2[len2-i-1]-'0';
	}
	for(int i=0;i<len1;i++)
	{
		for(int j=0;j<len2;j++)
		{
			c[i+j]=c[i+j]+a[i]*b[j];
		}
	}
	for(int i=0;i<len;i++)
	{
		if(c[i]>=10)
		{
			c[i+1]+=c[i]/10;
			c[i]=c[i]%10;
		}
	}
	
	while(c[len-1]==0&&len>=1) len--;
	for(int i=0;i<len;i++)
		prod[i]=c[len-i-1]+'0';
	prod[len]='\0';
		
	return prod;
}

int main()
{
	char s1[MAXLEN], s2[MAXLEN];
	while(cin>>s1>>s2)
	{
		cout<<multiply(s1,s2)<<endl;
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值