PAT甲级1020 Tree Traversals (25分)|C++实现

一、题目描述

原题链接
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

​​Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

二、解题思路

这是一道相对简单的二叉树的遍历题,题目给出二叉树的后序和中序遍历,让我们求层序遍历。事实上,这种题必须给出一个中序遍历,因为只有这样我们才可以确定根节点是哪个。我们可以用findRoot(int postL, int postR, int inL, int inR)函数找出这棵二叉树的根节点,随后对该根节点的左右孩子进行递归,则可构造出原来的二叉树。至于层序遍历,我们可以利用队列这个数据结构来实现。

三、AC代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn = 40;
int post[maxn], in[maxn];
vector<int> ans;
struct Node
{
    int key, lchild = -1, rchild = -1;
}node[maxn];
int findRoot(int postL, int postR, int inL, int inR)
{
    if(postL > postR)   return -1;
    int inRoot;
    for(int i=inL; i<=inR; i++)
    {
        if(node[i].key == post[postR])
        {
            inRoot = i;
            break;
        }
    }
    node[inRoot].lchild = findRoot(postL, postL + inRoot - inL - 1, inL, inRoot-1);
    node[inRoot].rchild = findRoot(postL + inRoot - inL, postR - 1, inRoot + 1, inR);
    return inRoot;
}
int main()
{
    int N;
    scanf("%d", &N);
    for(int i=1; i<=N; i++)  scanf("%d", &post[i]);
    for(int i=1; i<=N; i++)
    {
        scanf("%d", &in[i]);
        node[i].key = in[i];
    }
    int root = findRoot(1, N, 1, N);
    queue<int> q;
    q.push(root);
    while(!q.empty())
    {
        int now = q.front();
        q.pop();
        ans.push_back(node[now].key);
        if(node[now].lchild != -1)  q.push(node[now].lchild);
        if(node[now].rchild != -1)  q.push(node[now].rchild);
    }
    for(int i=0; i<ans.size(); i++)
        i == 0? printf("%d", ans[i]) : printf(" %d", ans[i]);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值