PAT 1138.Postorder Traversal(25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

通过先+中得到唯一树,后序遍历非递归实现

#include <stdio.h>
#include <stdlib.h>
#include <stack>
using namespace std;
#define null 0

typedef struct bitNode{
    int data;
    struct bitNode *lchild,*rchild;
}bitNode,*bitTree;

bitTree createTree(int pre[],int in[],int l1,int h1,int l2,int h2)
{
    bitNode *root = (bitNode *)malloc(sizeof(bitNode));
    root->data=pre[l1];
    int i;
    for(i=l2;in[i]!=root->data;i++);
    int llen = i-l2;
    int rlen = h2 - i;
    if(llen)
    {
        root->lchild=createTree(pre, in, l1+1, l1+llen, l2, l2+llen-1);
    }else
        root->lchild = null;
    if(rlen)
    {
        root->rchild=createTree(pre,in,h1-rlen+1,h1,h2-rlen+1,h2);
        //printf(" /%d/ ",root->rchild->data);
    }else
        root->rchild=null;
    return root;
}
stack<bitTree> s;
void postOrder(bitTree root)
{
    if(!root) return;
    bitTree p = root;
    bitNode *r = null;
    s.push(p);
    p=p->lchild;
    while(!s.empty())
    {
        if(p)
        {
            s.push(p);
            p=p->lchild;
        }else{
            p=s.top();
            if(p->rchild != null && p->rchild != r)
            {
                p=p->rchild;
                s.push(p);
                p=p->lchild;
            }else{
                s.pop();
                printf("%d\n",p->data);
                return;
            }
        }
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    int preOrder[50001];
    int InOrder[50001];
    for(int i=0;i<n;i++)
    {
        scanf("%d",&preOrder[i]);
    }
    for(int i=0;i<n;i++)
    {
        scanf("%d",&InOrder[i]);
    }
    bitTree p = createTree(preOrder, InOrder, 0, n-1, 0, n-1);
    postOrder(p);
    return 0;
}

不需要建树 通过递归判断

#include <iostream>
#include <vector>
using namespace std;
vector<int> pre, in;
bool flag = false;
void postOrder(int prel, int inl, int inr) {
    if (inl > inr || flag == true) return;
    int i = inl;
    while (in[i] != pre[prel]) i++;
    postOrder(prel+1, inl, i-1);
    postOrder(prel+i-inl+1, i+1, inr);
    if (flag == false) {
        printf("%d", in[i]);
        flag = true;
    }
}
int main() {
    int n;
    scanf("%d", &n);
    pre.resize(n);
    in.resize(n);
    for (int i = 0; i < n; i++) scanf("%d", &pre[i]);
    for (int i = 0; i < n; i++) scanf("%d", &in[i]);
    postOrder(0, 0, n-1);
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值