PAT甲级1042 Shuffling Machine (20分)|C++实现

一、题目描述

原题链接
Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2
where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

在这里插入图片描述

​​Output Specification:

在这里插入图片描述

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

二、解题思路

这道题实际上就是让我们把原来固定的一个字符串数组(或vector)按照规定的顺序重新排列,用重新排列这个词可能还有点不太好实现,我们可以说按照一定的顺序填入另外一个数组,那么这里我们的思想就是,建立一个字符串的vector,一个用于存放一开始的牌组,另一个用于存放排列之后的牌组。我们可以用一个数组order来存放题目给出的顺序,随后我们就可以遍历这个数组,更新ans[order[i] - 1],随后要把之前用于存放初始牌组的vector再进行一次更新,以便下一次洗牌。

三、AC代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
using namespace std;
char ch[4] = {'S', 'H', 'C', 'D'};
string num[13] = {"1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13"};
vector<string> str;
void init()
{
    string tmp, head;
    for(int i=0; i<4; i++)
    {
        head = ch[i];
        for(int j=0; j<13; j++)
        {
            tmp = head + num[j];
            str.push_back(tmp);
            tmp.clear();
        }
    }
    str.push_back("J1");
    str.push_back("J2");
}
int main()
{
    int repeat;
    string ans[54];
    int order[54];
    init();
    scanf("%d", &repeat);
    for(int i=0; i<54; i++) scanf("%d", &order[i]);
    for(int j=0; j<repeat; j++)
    {
        for(int k=0; k<54; k++) ans[order[k]-1] = str[k];
        for(int l=0; l<54; l++) str[l] = ans[l];
    }
    cout << ans[0];
    for(int i=1; i<54; i++) cout << " " << ans[i];
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值