PAT_A1042 | Shuffling Machine

1042 Shuffling Machine (20分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

 

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

 

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 


简单分析:

题目比较简单,分析一下我思考的几个要点:

🔺对输入的换牌规律的处理:

直接读入完整的一行存入字符串数组,然后再依次拆分成每个数存入数组number中。

🔺洗牌的处理:

1、用一个数组card,专门才储存牌当下的顺序,从0~53依次为每张牌的顺序。

2、为了方便,默认将最初的54张牌一一对应从0~53编号。

3、每次交换就是按照number数组排序,存入新的card1数组中。即依次实现card1[number[i]] = card[i]

🔺输出的处理:

按照最后储存在card数组中的顺序对应牌输出即可,编号和牌的对应规律很好找到。

 

 

需要注意的点:

1、洗牌的对应方式一定要想清楚

2、正确处理输入

3、输出时最后不要加空格

 

话不多说,直接上代码:

#include <iostream>

#define NUM 54
#define LENGTH 250
using namespace std;

/* num为输入的字符串,数字用空格隔开
 * 将54个数字分割后依次存入number数组中 */
void getNumber(char num[], int number[]){
    int j = 0;
    for(int i = 0; num[i] != '\0'; i++) {
        int t = 0;
        while(num[i] != ' ' && num[i] != '\0') {
            t = t * 10 + num[i] - '0';
            i++;
        }
        number[j++] = t;
    }
}

/*一次洗牌的过程
 * 原本牌序储存再card
 * 按照number洗牌完后再存入card*/
void change(int card[], int number[]) {
    int card1[NUM] = {0};
    for(int i = 0; i < NUM; i++) {
        card1[number[i] - 1] = card[i];
    }
    /*覆盖*/
    for(int i = 0; i < NUM; i++) {
        card[i] = card1[i];
    }
}

/* 按照card中的顺序
 * 根据编号依次打印纸牌 */
void print(int card[]) {
    for(int i = 0; i < NUM; i++) {
        switch (card[i] / 13) {
            case 0:
                printf("S");
                break;
            case 1:
                printf("H");
                break;
            case 2:
                printf("C");
                break;
            case 3:
                printf("D");
                break;
            case 4:
                printf("J");
                break;
        }
        printf("%d", card[i] % 13 + 1);
        if(i != NUM - 1)
            putchar(' ');
    }
    printf("\n");
}

int main() {

    int card[NUM];  //纸牌序号
    /* 从 0 到 54依次对纸牌编号*/
    for(int i = 0; i < NUM; i++) {
        card[i] = i;
    }

    int repeatTime;
    scanf("%d\n", &repeatTime);

    char num[200];   //输入的字符串
    int number[NUM];  //每次的洗牌顺序
    cin.getline(num, LENGTH);

    getNumber(num, number);   //处理输入字符串,存入对应数组

    for(int i = 0; i < repeatTime; i++)
        change(card, number);


    print(card);

    return 0;
}
 

 



End

欢迎关注个人公众号“鸡翅编程”,这里是认真且乖巧的码农一枚,旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值