【Codeforces】1216B - Shooting

Problem Description:

Recently Vasya decided to improve his pistol shooting skills. Today his coach offered him the following exercise. He placed n cans in a row on a table. Cans are numbered from left to right from 1 to n. Vasya has to knock down each can exactly once to finish the exercise. He is allowed to choose the order in which he will knock the cans down.

Vasya knows that the durability of the i-th can is a_{i}. It means that if Vasya has already knocked x cans down and is now about to start shooting the i-th one, he will need (a_{i}⋅x+1)shots to knock it down. You can assume that if Vasya starts shooting the i-th can, he will be shooting it until he knocks it down.

Your task is to choose such an order of shooting so that the number of shots required to knock each of the n given cans down exactly once is minimum possible.

Input Specification:

The first line of the input contains one integer n (2≤n≤1000) — the number of cans.

The second line of the input contains the sequence a_{1},a_{2},…,a_{n} (1≤a_{i}≤1000), where aiai is the durability of the i-th can.

Output Specification:

In the first line print the minimum number of shots required to knock each of the n given cans down exactly once.

In the second line print the sequence consisting of n distinct integers from 1 to n — the order of indices of cans that minimizes the number of shots required. If there are several answers, you can print any of them.

Sample Input1:

3
20 10 20

Sample Output1:

43
1 3 2 

Sample Input2:

4
10 10 10 10

Sample Output2:

64
2 1 4 3 

Sample Input3:

6
5 4 5 4 4 5

Sample Output3:

69
6 1 3 5 2 4 

Sample Input4:

2
1 4

Sample Output4:

3

2 1

Note:

In the first example Vasya can start shooting from the first can. He knocks it down with the first shot because he haven't knocked any other cans down before. After that he has to shoot the third can. To knock it down he shoots 20⋅1+1=21 times. After that only second can remains. To knock it down Vasya shoots 10⋅2+1=21 times. So the total number of shots is 1+21+21=43.

In the second example the order of shooting does not matter because all cans have the same durability.

解题思路:

题目大意是:给定n个罐子,第i个罐子a[i]需要射击 (a[i]*x+1) 次,问击倒n个罐子最少需要射击多少次,并输出罐子的初始编号。既然要求最少射击次数,那就用贪心算法吧。我们从需要射击最多次的罐子来开始。我太懒了 不想自定义结构体,然后我就用了一个pair,其中pair的first是击倒罐子所需的射击次数,second是罐子的初始编号,根据first来进行降序排列,然后用sum累加a[i]*x+1进行输出,最后再输出罐子的初始下标second即可。

AC代码:

#include<bits/stdc++.h>
using namespace std;
#define Up(i,a,b) for(int i = a; i <= b; i++)
#define P pair<int,int>  //first是值,second是初始下标
#define mp(x,y) make_pair(x,y)
 
bool cmp(P p1, P p2)
{
	return p1.first > p2.first; 
}
 
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0),cout.tie(0);
	vector<P> v;
	int n;
	cin >> n;
	Up(i,1,n)
	{
		int _;
		cin >> _;
		v.push_back(mp(_,i));
	}
	sort(v.begin(),v.end(),cmp);
	int x = 0,sum = 0,sz = v.size()-1;
	Up(i,0,sz)
	{
		sum += v[i].first*x+1;
		x++;
	}
	cout << sum << endl;
	Up(i,0,sz)
	{
		cout << v[i].second << (i==sz?"\n":" ");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

喜欢ctrl的cxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值