Express Mail Taking

Express Mail Taking

题目链接
Problem Description
Besides on the traditional classes,Baby Volcano also needs to learn how to take the express mails.

Usually express mails are stored in cabinets. In Baby Volcano’s school,there are n cabinets in a row,numbered by 1 to n. The distance between two adjacent cabinets is 1, and the entrance is at the cabinet 1. Among all n cabinets,the one numbered k is special and it is used to enter the code and open the cabinet door.

Baby Volcano has m express mails to take,the i-th is in the cabinet ai.
Two express mails will not be stored in the same cabinet. Also there is no express mail in the cabinet k.

To prevent expresses from being stolen, Baby Volcano have to take these express mails one by one, starting at the entrance. Generally, if he wants to take the express mail i, he have to walk to cabinet k first to enter the code, and then walks to cabinet ai. After taking the last one,he walks to the entrance.

There are so many express mails to take, so Baby Volcano wants to find a taking order which minimize the distance he walks.

Input
The first line contains one integer T(1≤T≤100),the number of testcases.

For each test cases,the first line contains three integer n,m,k(1≤k≤n≤109,1≤m<min(n,106))

The next line contains m integer,the i-th stand for ai(1≤ai≤n,ai≠k).

The input guarantees that ∑m≤2×106

Note:Because of the large input,it is prefered to use scanf instead of cin.

Output
For each test case,Output a single line contains one integer,representing for the minimal walking distance.

Sample Input
2
10 2 5
6 7
10 2 5
3 4

Sample Output
14
10

题意:
开始位置为1,m位置后开始,到某个包裹,让后回到m,在到某个包裹,再回来。。。。最后回到位置1。求最短路径。

解题思路:
由于中间过程,和开头是确定的,所以优化只能在最后回去的选择上。因此,当最后一次取包裹在距离位置1最近的位置,即可获得最短路径。
AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e6+100;
ll n,m,k,a[maxn];
int main(){
	int t;
	cin>>t;
	while(t--){
		ll sum=0,min_=1e9+10;	
		scanf("%lld %lld %lld",&k,&n,&m);
		sum=m-1;
		for(int i=0;i<n;i++){
			scanf("%lld",&a[i]);
			sum+=2*abs(a[i]-m);
			min_=min(min_,a[i]);
		} 
		sum=sum+min_-1-abs(min_-m);
		cout<<sum<<endl;
	}
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值