10:Best Cow Line, GoldMOOC程序设计算法基础期末第十题

FJ is about to take his N (1 <= N <= 30,000) cows to the annual "Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (e.g., If FJ takes Bessie, Sylvia, and Dora in that order, he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order (i.e., alphabetical order) according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

输入

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

输出

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the newline.

样例输入

6
A
C
D
B
C
B

样例输出

ABCBCD

提示

INPUT DETAILS:

FJ has 6 cows in this order: ACDBCB

OUTPUT DETAILS:

  Step   Original     New
   #1     ACDBCB
   #2      CDBCB     A
   #3      CDBC      AB
   #4      CDB       ABC
   #5      CD        ABCB
   #6       D        ABCBC
   #7                ABCBCD

直接模拟,如果首尾相同时需要加以判断

AC代码:
 

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int main()
{
	int n;
	cin>>n;
	vector<char> op,pq;//op存储新的序列,pq存储原序列
	for(int i=0;i<n;++i){
		char tmp;
		cin>>tmp;
		pq.push_back(tmp);
	}
	while(pq.size()){
		if(pq[0]<pq[pq.size()-1]) op.push_back(pq[0]),pq.erase(pq.begin());
		else if(pq[0]>pq[pq.size()-1]) op.push_back(pq[pq.size()-1]),pq.erase(pq.begin()+pq.size()-1);
		else{//相等时加以判断
			int i=0,j=pq.size()-1;
			while(i<=j&&pq[i]==pq[j]){++i;--j;}
			if(pq[i]<pq[j]) op.push_back(pq[0]),pq.erase(pq.begin());
			else op.push_back(pq[pq.size()-1]),pq.erase(pq.begin()+pq.size()-1);
		}
	}
	int cnt=0;
	for(int i=0;i<op.size();++i){
		if(cnt==80) cout<<endl,cnt=0;//输出格式要求
		++cnt;
		cout<<op[i];
	}
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值