浙大PTA甲级1155

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
给出一棵层次遍历的有n个结点的树,输出 从右到左的 从根结点到每个叶子结点的路径,并判断大小顶堆。

大/小顶堆:每个结点都比自己的子节点大/小。

(下标0开始)二叉树结点为x,左结点为2x+1,右结点为2x+2。

由根结点往下深搜,当搜到叶子节点(用x*2+1>=n判断,即不存在左子树)时,直接输出,回溯的时候弹出该结点。

在这里插入代码片#include<iostream>
#include<vector>
using namespace std;
vector<int> v[1000];
int num;
int flagmax = 0;//判断大小堆,如果两个都是1就不是堆
int flagmin = 0;
vector<int> result;
void fps(int a) {//遍历
	result.push_back(v[a][0]);
	if (v[a].size()==3) {
		fps(a * 2 + 1);
		fps(a * 2);
		result.pop_back();
	}
	else if (v[a].size() == 2) {
		fps(a * 2);
		result.pop_back();
	}
	else {
		cout << result[0];
		for (int i = 1; i < result.size(); i++) {
			cout << " " << result[i];
		}
		cout << endl;
		result.pop_back();
	}
	
}
int main() {
	
	cin >> num;
	for (int i = 1; i <= num; i++) {
		int a;
		cin >> a;
		v[i].push_back(a);
	}
	for (int i = 1; i < num/2; i++) {
		v[i].push_back(v[2 * i][0]);
		v[i].push_back(v[2 * i + 1][0]);
	}
	if (num % 2) {
		v[num / 2].push_back(v[num - 1][0]);
		v[num / 2].push_back(v[num][0]);
	}
	else {
		v[num/2].push_back(v[num][0]);
	}
	fps(1);
	for (int i = 1; i < num / 2; i++) {
		if (v[i].size() == 2) {
			if (v[i][0] > v[i][1]) {
				flagmax = 1;
			}
			else if(v[i][0] < v[i][1]){
				flagmin = 1;
			}
		}
		else if(v[i].size() == 3)
		{
			if (v[i][0] > v[i][1]&& v[i][0] > v[i][2]) {
				flagmax = 1;
			}
			else if(v[i][0] < v[i][1] && v[i][0] < v[i][2]){
				flagmin = 1;
			}
		}
	}
	if (flagmax == 1 && flagmin == 0) {
		cout << "Max Heap" << endl;
	}
	else if (flagmin == 1 && flagmax == 0) {
		cout << "Min Heap" << endl;
	}
	else {
		cout << "Not Heap" << endl;
	}
}

哪里错了啊,或者说有什么极端情况。。

在这里插入图片描述
跑出来是这样的

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值