PTA甲级1155

PTA甲级1155

自述:

本菜鸡终于开始写博客了哈哈哈哈哈

正文:

先看甲级的这一道题目

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目分析:

其实就是让我们检查题目中所给出的完全二叉树是不是堆(最大堆or最小堆)

输入:树上的结点个数N(1000以内)

N个完全不同的键值(int范围以内)

给出了这个完全二叉树的层序遍历结果

输出:首先打印从根节点到叶子节点的全部路径,每个一行

右边的路径优先于左边的路径打印

该怎么做:

具体的话可以用线性数组构建二叉树,用DFS从右到左输出,遍历时判断父子大小关系来判断是不是满足堆的要求

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
int tree[maxn];
int path[maxn];//path[i]路径上的i号对应tree[i]
int n;
bool maxheap,minheap;
//如果从根到叶子dfs的过程中,父节点有大于子结点的情况,那么maxheap为true;minheap同理
void dfs(int rt,int pos){
	//当前遍历到的根节点rt,当前结点在路径的位置pos
	path[pos]=rt;
	if(rt*2>n){//此时rt是叶子结点
		for(int i=0;i<=pos;++i){
			if(i==pos)printf("%d\n",tree[path[i]]);
			else printf("%d ",tree[path[i]]);
		}
		return;
	}
	int lc=rt*2;//左孩子
	int rc=rt*2+1;//右孩子标号
	if((lc<=n&&tree[lc]<tree[rt])
		||(rc<=n&&tree[rc]<tree[rt]))maxheap=true;
	if((lc<=n&&tree[lc]>tree[rt])
		||(rc<=n&&tree[rc]>tree[rt]))minheap=true;

	//先遍历右孩子
	if(rc<=n)dfs(rc,pos+1);
	if(lc<=n)dfs(lc,pos+1);
}
int main(){
	while(scanf("%d",&n)!=EOF){
		for(int i=1;i<=n;++i)
			scanf("%d",&tree[i]);
		maxheap=false;
		minheap=false;
		dfs(1,0);
		if(maxheap&&minheap)printf("Not Heap\n");
		else if(maxheap)printf("Max Heap\n");
		else  printf("Min Heap\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值