PAT甲级【2019年3月考题】——A1156 SexyPrimes【20】

Sexy primes are pairs of primes of the form (p, p+6), so-named since “sex” is the Latin word for “six”. (Quoted from http://mathworld.wolfram.com/SexyPrimes.html)

Now given an integer, you are supposed to tell if it is a sexy prime.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤108 10^810
8
​​ ).

Output Specification:
For each case, print in a line Yes if N is a sexy prime, then print in the next line the other sexy prime paired with N (if the answer is not unique, output the smaller number). Or if N is not a sexy prime, print No instead, then print in the next line the smallest sexy prime which is larger than N.

Sample Input 1:
47
Sample Output 1:
Yes
41
Sample Input 2:
21
Sample Output 2:
No
23
 

【声明】

  由于此题还未上PAT官网题库,故没有测试集,仅仅是通过了样例,若发现错误,感谢留言指正。

Solution:

  这道题很简单,就是判断一下n 以及 n-6 或者 n+6是素数,不是的话,那就n++,直到满足要求

#include <iostream>
using namespace std;
bool isPrime(int x)//判断是不是素数
{
	if (x < 3)
		return x >= 1;
	for (int i = 2; i*i <= x; ++i)
		if (x%i == 0)
			return false;
	return true;
}
int isSexyPrimes(int x)//判断满不满足题目要求
{
	if (isPrime(x))
	{
		bool fL = isPrime(x - 6), fR = isPrime(x + 6);
		if (fL || fR)
			return fL ? x - 6 : x + 6;
	}
	return -1;
}
int main()
{
	int n;
	cin >> n;
	int res = isSexyPrimes(n);
	if (res > 0)
	{
		printf("Yes\n");
		printf("%d\n", res);
	}
	else
	{
		printf("No\n");
		for (int i = n + 1; i < INT32_MAX; ++i)//另寻找大数,直至满足要求
		{
			if (isSexyPrimes(i) > 0)
			{
				printf("%d\n", i);
				break;
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值