HDU - 1213 How Many Tables 【并查集】

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1213

 

Problem Description(下方有汉语题意)

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

 

Sample Input

2 
5 3 
1 2 
2 3 
4 5 

5 1 
2 5

 

Sample Output

2 
4

题意

有n个人去吃饭,认识的人可以坐在一桌(A认识B,B认识C,那么认为A和C认识),不认识的不能坐在一桌,问至少需要几桌。

解题思路

并查集模板题

AC代码:

#include <iostream>
using namespace std;
int f[1005],N,M;
void init()
{
    for(int i=1;i<=N;i++)
        f[i]=i;
    return;
}
int getf(int x)
{
    if(f[x] == x)
        return x;
    f[x]=getf(f[x]);
    return f[x];
}
void Merge(int t1,int t2)
{
    int f1,f2;
    f1 = getf(t1);
    f2 = getf(t2);
    if(f1 != f2)
        f[f2] = f1;
    return;
}
int main()
{
    int T,ans;
    cin >> T;
    while( T--) {
        cin >> N >> M;
        init();
        int t1,t2;
        for(int j=0;j<M;j++) {
            cin >> t1 >> t2;
            Merge(t1,t2);
        }
        ans = 0;
        for(int j=1;j<=N;j++)
            if(f[j] == j)
                ans++;
        cout << ans << endl;
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值