HDU-1213 How Many Tables(并查集基础)

2 篇文章 0 订阅
2 篇文章 0 订阅

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

题目大意:

      有人过生日要准备桌子,他希望认识的人坐在同一张桌子,让我们求最少需要多少桌子

解题思路:

      很简单的裸的并查集,对于给定的关系做Union操作,最后看有多少个集合就行

#include<iostream>

using namespace std;

const int maxN = 1010;

int parentArr[maxN];
//查找根节点
int getParent(int x) {
    //不是根节点
    while(parentArr[x] != x) {
        x = parentArr[x];
    }
    return x;
}

//两个集合的合并
void Union(int x, int y) {
    int xParent = getParent(x);
    int yParent = getParent(y);
    //两个集合不属于同一个集合
    if(xParent != yParent) {
        //进行合并
        parentArr[yParent] = xParent;
    }
}

int main() {
    int t, n, m, x, y, res;
    cin >> t;
    while(t--) {
        cin >> n >> m;
        //初始化
        res = 0;
        for(int i = 1;i <= n;i++) {
            parentArr[i] = i;
        }
        for(int i = 1;i <=m;i++) {
            cin >> x >> y;
            //将两个集合合并
            Union(x,y);
        }
        //查找有几个不同的集合
        for(int i = 1;i <= n;i++) {
            if(parentArr[i] == i) {
                res++;
            }
        }
        cout << res << endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值