HDU - 2473 Junk-Mail Filter 【并查集删点】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2473

Description(汉语题意在下方)

Recognizing junk mails is a tough task. The method used here consists of two steps: 
1) Extract the common characteristics from the incoming email. 
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam. 

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations: 

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so 
relationships (other than the one between X and Y) need to be created if they are not present at the moment. 

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph. 

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N. 
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file. 
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above. 
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2

题意:

两个整数n,m;n代表邮件数(下标从0开始),m代表下面会给出几行操作。 M x y 表示把x y放到一个集合中,S x表示把x从集合中(如果在集合中)拿出来单独成一个集合,最后让你求有几个集合。

解题思路

并查集删点的核心是虚拟父结点,假如现在有n个点,编号为0~n-1, 我们初始化父结点的值时,令0的父结点为0+n = n 而不是它本身,即0~n-1的父结点为n~2*n-1,并同时设置t = 2*n,删除某个结点时,令他找新父亲t,即令他的父节点为t,同时t++,以便下次删除。  为什么要这么做?? 手动模拟画一下初始化并查集父结点为本身以及这种情况下多次 merge和 delete的,你会发现神奇之处。实现并查集删点并不一定要用这种方式设置父结点,但是以这种方式设置父节点最节省空间的。

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 2e6;
int f[maxn];
bool vis[maxn];
void init(int n,int m)
{
	for(int i=0;i<n;i++)
		f[i] = n+i;
	for(int i=n;i<2*n+m;i++)
		f[i] = i;
}
int getf(int x) 
{
	if(f[x] == x) return x;
	return f[x] = getf(f[x]);  
} 
void Merge(int x,int y)
{
	int fx = getf(x);
	int fy = getf(y);
	if(fx != fy)
		f[fy] = fx;
}
int main()
{
	int n,m;
	int Case = 0;
	while(scanf("%d%d",&n,&m) && (n || m)) {		//要用 或! 
		init(n,m);
		char ch[5];
		int t1,t2;
		int _next = 2*n;
		for(int k=1;k<=m;k++) {
			scanf("%s",ch);
			if(ch[0] == 'M') {
				scanf("%d%d",&t1,&t2);
				Merge(t1,t2);
			}	
			else {
				scanf("%d",&t1);	
				f[t1] = _next++;
			}
		}
		memset(vis,false,sizeof vis);
		int ans = 0,k;
		for(int i=0;i<n;i++) {
			k = getf(i);
			if(!vis[k]) {
				ans++;
				vis[k] = true;
			}
		}
		printf("Case #%d: %d\n",++Case,ans);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值