并查集删边-HDU2473-Junk-Mail Filter

正确的删边方法,并不是真正的删掉,而是设立虚父节点,这也是我目前知道的唯一删边操作了

Description

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0

Sample Output

Case #1: 3
Case #2: 2
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<set>
#include<algorithm>
using namespace std;
int node[100005];
int fa[100005];
int n,m,u,v,T=1,N;
void init()
{
    for(int i=0;i<n;i++)
    {
        fa[i]=i;
        node[i]=i;
    }
}
int father(int u)
{
    if(u==fa[u])
        return u;
    else
        return fa[u]=father(fa[u]);
}
void unite(int u,int v)
{
    int nu=father(u);
    int nv=father(v);
    if(nu!=nv)
    {
        fa[nv]=nu;
    }
}
void delete1(int u)
{
    node[u]=n;
    fa[n]=n++;
}
int main()
{
    char s[10];
    while(~scanf("%d%d",&n,&m)&&n+m)
    {
        N=n;
        init();
        while(m--)
        {
            scanf("%s",s);
            if(s[0]=='M')
            {
                scanf("%d%d",&u,&v) ;
                unite(node[u],node[v]) ;
            }
            if(s[0]=='S')
            {
                scanf("%d",&u);
                delete1(u);
            }
        }
        printf("Case #%d: ",T++) ;
        set<int> se;
        for(int i=0; i<N; i++)
            se.insert(father(node[i]));
        printf("%d\n",se.size());
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值