POJ - 3624 Charm Bracelet(0-1背包)【动态规划】

题目链接:http://poj.org/problem?id=3624

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

分析:

这题最容易想到的做法需要用到二维数组,结果爆内存。搜了下才知道这是经典的0-1背包问题,需要对空间进行优化,即用一维数组来代替二维数组。至于怎么代替,以为为什么要从M->最小容量, MOOC(https://www.icourse163.org/learn/PKU-1001894005?tid=1003186011#/learn/content?type=detail&id=1004501049&sm=1)上讲很清楚。

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
struct goods {
    int w, d;
}g[3505];
//int MaxC[2505][12885];
int MaxC[13000];
int main()
{
    int N,M;

    while(cin >> N >> M) {
        for(int i=1;i<=N;i++)
        cin >> g[i].w >> g[i].d;

    /*
        for(int i=0;i<=N;i++)
            MaxC[i][0] = 0;
        for(int i=0;i<=M;i++)
            MaxC[0][i] = 0;

        for(int i=1;i<=N;i++) {
            for(int j=1;j<=M;j++) {
                if(g[i].w <= j)
                    MaxC[i][j] = max(g[i].d + MaxC[i-1][j-g[i].w],MaxC[i-1][j]);
                else
                    MaxC[i][j] = MaxC[i-1][j];
            }
        }
    */
        for(int i=0;i<=M;i++)
            MaxC[i] = 0;

        for(int i=1;i<=N;i++) {
            for(int j=M;j>=g[i].w;j--)      // 需要从后往前推!!!
                MaxC[j] = max(MaxC[j],MaxC[j-g[i].w]+g[i].d);
        }

    //    cout << MaxC[N][M] << endl;
        cout << MaxC[M] << endl;
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值