1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
【分析】多项式相加。
总结:
1. double 类型数据输入时需要用%ld !!
2. map的反向输出
3. 边界值的判断
#include <iostream>
#include <map>
using namespace std;
static const int maxn = 1e3 + 5;
int k1, k2;
map<int, double> m;
int main() {
scanf("%d", &k1);
for (int i = 0; i < k1; i++) {
int exp;
double coe;
scanf("%d%lf", &exp, &coe);
m[exp] = coe;
}
scanf("%d", &k2);
for (int i = 0; i < k2; i++) {
int exp;
double coe;
scanf("%d%lf", &exp, &coe);
m[exp] += coe;
if (m[exp] == 0) {
map<int, double>::iterator it = m.find(exp);
m.erase(it);
}
}
if (m.size() != 0) printf("%d ", m.size());
else printf("0");
int ans = 0;
for (map<int, double>::reverse_iterator rit = m.rbegin(); rit != m.rend(); rit++) {
printf("%d %.1f", rit->first, rit->second);
if (ans++ != m.size() - 1) printf(" ");
// else printf("**");
}
return 0;
}