CSU暑期集训day01_H_Compound Words

题目:

    You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

    Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

    Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a

alien

born

less

lien

never

nevertheless

new

newborn

the

zebra

Sample Output

alien

newborn

 

题目大意:

    给出一些单词,要求找出那些由两个其它单词组成的单词。

解题思路:

    用set存储单词,暴力判断每一个单词是否是组合单词。

代码:

#include <iostream>
#include <set>
#include <string>

using namespace std;

int main(){
    set<string> ss;
    string str;
    while(cin>>str){
        //if(str=="0")break;
        ss.insert(str);
    }
    set<string>::iterator ite;
    for(ite=ss.begin();ite!=ss.end();ite++){
        int le=(*ite).length();
        string cur=*ite;
        for(int i=1;i<le;i++){
            string left=cur.substr(0,i);
            string right=cur.substr(i);
            if(ss.count(left)&&ss.count(right)){
                cout<<cur<<endl;
                break;
            }
        }
    
    }
    return 0; 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值