CSU暑期集训day02_C_浮点数二分

题目:

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

题目大意:

    给出一个带参数的方程,根据每次给出的参数求出该方程的的近似解。

解题思路:

     二分法逐次逼近,上下界已给出,判断方法就是带入计算方程值。

代码:

#include <iostream>
#include <iomanip>
#include <cstdio> 
#include <cmath>

using namespace std;

double fun(double x){
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}

int main(){
    int T;
    cin>>T;
    while(T--){
        double y;
        scanf("%lf",&y);
        double left=0;
        double right=100;
        if(y<fun(0)||y>fun(100)){
            cout<<"No solution!"<<endl;
        }
        else {
            double mid;
            while(right-left>1e-8){
                mid=(left+right)/2.0;
                if(fun(mid)<=y)left=mid;
                else right=mid;        
            }
            printf("%.4lf\n",mid);
        }    
    } 
    system("pause");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值