Til the Cows Come Home(最短路-Dijkstra)

Til the Cows Come Home(最短路-Dijkstra)

judge:https://vjudge.net/contest/297882#problem/A
Time limit:1000 ms
Memory limit:65536 kB
OS:Linux

描述

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

题意

贝西在田里,想在农夫约翰叫醒她早上挤奶之前回到谷仓尽可能多地睡一觉。贝西需要她的美梦,所以她想尽快回来。

农场主约翰的田里有n(2<=n<=1000)个地标,唯一编号为1…n。地标1是谷仓;贝西整天站在其中的苹果树小树林是地标n。奶牛在田里行走时使用地标间不同长度的T(1<=t<=2000)双向牛道。贝西对自己的导航能力没有信心,所以一旦开始,她总是沿着一条从开始到结束的路线行进。

根据地标之间的轨迹,确定贝西返回谷仓必须走的最小距离。这样的路线一定存在。

输入

*第1行:两个整数:t和n

*第2.t+1行:每行将一条轨迹描述为三个空格分隔的整数。前两个整数是两条轨迹之间的标志。第三个整数是跟踪的长度,范围为1…100。

输出

*第1行:一个整数,贝西从地标N到地标1的最小距离。

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

思路

简单最短路,Dijkstra走一波(闲着没事顺便写了个优先级队列优化版,把时间复杂度从O(n2)降到O(n*log(n)),同时用邻接链表代替邻接矩阵降低空间复杂度)

代码一般版

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <vector>
#include <cstring>
#define inf 0x3f3f3f3f
#define maxn 2005
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i <= (b); i++)
using namespace std;
int N, M;
int S, T;
int dis[maxn];
int mp[maxn][maxn];
bool vis[maxn];
void Dijkstra() {
	dis[S] = 0;
	_for(i, M) {
		int k = 0, tem = inf;
		_rep(j, 1, M) {
			if (!vis[j] && dis[j] < tem) {
				k = j;
				tem = dis[j];
			}
		}
		vis[k] = 1;
		if (tem == inf) break;
		_rep(j, 1, M) {
			if (!vis[j] && dis[j] > dis[k] + mp[k][j])
				dis[j] = dis[k] + mp[k][j];
		}
	}
}
int main() {
	//freopen("in.txt", "r", stdin);
	while (~scanf("%d%d", &N, &M)) {

		//初始化
		_rep(i, 1, M) {
			dis[i] = inf;
			mp[i][i] = 0;
			_rep(j, 1, i - 1)
				mp[j][i] = mp[i][j] = inf;
		}
		memset(vis, 0, sizeof(vis));

		S = 1, T = M;
		_rep(i, 1, M) mp[i][i] = 0;
		_for(i, N) {
			int A, B, X;
			scanf("%d%d%d", &A, &B, &X);
			if (mp[A][B] > X)
				mp[A][B] = mp[B][A] = X;
		}
		Dijkstra();
		printf("%d\n", dis[T]);
	}
	return 0;
}

代码优化版

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <vector>
#include <cstring>
#define inf 0x3f3f3f3f
#define maxn 2005
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i <= (b); i++)
using namespace std;
struct poi {
	int x, w;

	poi() {}
	poi(int a, int b) :x(a), w(b) {}
	bool operator < (const poi tem) const {
		return tem.w < w;
	}
};
int N, M;
int S, T;
int dis[maxn];
vector<poi> mp[maxn];
bool vis[maxn];
void Dijkstra() {
	dis[S] = 0;
	_for(i, M) {
		int k = 0, tem = inf;
		priority_queue<poi> que;
		que.push(poi(S, 0));
		vis[S] = 1;

		while (que.size()) {
			poi tem = que.top();
			que.pop();
			vis[tem.x] = 0;
			_for(i, mp[tem.x].size()) {
				int c = mp[tem.x][i].x;
				if (dis[c] > dis[tem.x] + mp[tem.x][i].w) {
					dis[c] = dis[tem.x] + mp[tem.x][i].w;
					if (!vis[c]) {
						que.push(poi(c, dis[c]));
						vis[c] = 1;
					}
				}
			}
		}
	}
}
int main() {
	//freopen("in.txt", "r", stdin);
	while (~scanf("%d%d", &N, &M)) {

		/
		//初始化
		_rep(i, 1, M) {
			dis[i] = inf;
		}
		memset(vis, 0, sizeof(vis));
		//

		S = 1, T = M;
		_for(i, N) {
			int A, B, X;
			scanf("%d%d%d", &A, &B, &X);
			mp[A].push_back(poi(B, X));
			mp[B].push_back(poi(A, X));
		}
		Dijkstra();
		printf("%d\n", dis[T]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值