Til the Cows Come Home(dijkstra)

题目连接: Til the Cows Come Home

题目:

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input
Line 1: Two integers: T and N
Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

Output
Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90

解题思路:

本题的算法是迪科斯彻的最短路径算法, 该算法是一种十分稳定且高效的算法.
其核心思想是一样的, 都是贪心的思维, 用一个dis数组来存放所有点到起始点的距离, 然后每次选出距离起始点最近的点, 一直维护dis数组, 直至找到所有点(或者所求点)到起始点的距离.

AC代码: 复杂度 O(n2)

#include <bits/stdc++.h>
typedef long long ll;
using namespace std;
const int MAXN = 1005, INF = 0x3f3f3f3f;
int mp[MAXN][MAXN]; //图
int dis[MAXN]; //记录所有点与起始点的距离
bool vis[MAXN]; //记录起始点到该点是否已经距离最短
int t, n;
void initialize() {
	cin >> t >> n;
	memset(dis, 0x3f, sizeof(dis));
	memset(mp, 0x3f, sizeof(mp)); //默认所有点不可达
	memset(vis, 0, sizeof(vis)); vis[1] = 1;
	for (int i = 0; i < t; ++i) {
		int a, b, c;
		scanf("%d %d %d", &a, &b, &c);
		if (c < mp[b][a]) mp[b][a] = mp[a][b] = c;
	}
	for (int i = 2; i <= n; ++i) dis[i] = mp[1][i];
}
void dijkstra() {
	for (int i = 0; i < n - 1; ++i) {
		int index = 0, temp = INF;
		for (int j = 1; j <= n; ++j) { //找到起始点的所有可达点中 路径最短的
			if (dis[j] < temp && !vis[j]) index = j, temp = dis[j];
		}
		if (temp == INF || index == n) break; 
		vis[index] = 1;
		for (int j = 1; j <= n; ++j) { //维护dis
			dis[j] = min(dis[j], dis[index] + mp[index][j]);
		}
	}
	cout << dis[n] << endl;
}
int main(void)
{
	initialize();
	dijkstra();
	return 0;
}

END

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逍遥Fau

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值