7-23 还原二叉树

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入格式:

输入首先给出正整数N(≤50),为树中结点总数。下面两行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区别大小写)的字符串。

输出格式:

输出为一个整数,即该二叉树的高度。

输入样例:

9
ABDFGHIEC
FDHGIBEAC
输出样例:

5

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
typedef char ElemType;
typedef struct BiTreeType{
	ElemType data;
	struct BiTreeType *lchild,*rchild;
}BiTreeNode,*BiTree;
BiTree PreInorder(char preord[],char inord[],int i,int j,int k,int h)
{
	BiTree t;
	int m;
	t=(BiTreeNode *)malloc(sizeof(BiTreeNode));
	t->data=preord[i];
	m=k;
	while(inord[m]!=preord[i])
	 m++;
	if(m==k)
	 t->lchild=NULL;
	else
	 t->lchild=PreInorder(preord,inord,i+1,i+m-k,k,m-1);
	if(m==h)
	 t->rchild=NULL;
	else
	 t->rchild=PreInorder(preord,inord,i+m-k+1,j,m+1,h);
	return t;
}
BiTree CreateBiTree(char preord[],char inord[],int n)
{
	BiTree root;
	if(n<=0)
	 root=NULL;
	else
	 root=PreInorder(preord,inord,0,n-1,0,n-1);
	 return root;
}
int BitreeDepth(BiTree root)
{
	int d=0,depthl,depthr;
	if(root==NULL)
	 return 0;
	depthl=BitreeDepth(root->lchild);
	depthr=BitreeDepth(root->rchild);
	if(depthl>depthr)
	 d=depthl;
	else
	 d=depthr;
	return d+1;
}
int main()
{
	int n;
	BiTree root;
	scanf("%d",&n);
	char preord[50],inord[50];
	scanf("%s",preord);
	getchar();
	scanf("%s",inord);
	root=CreateBiTree(preord,inord,n);
	n=BitreeDepth(root);
	printf("%d",n);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值