【acm2028】 最小公倍数

***问题:
Problem Description
求n个数的最小公倍数。

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input
2 4 6
3 2 5 7

Sample Output
12
70***

代码:

#include<iostream>
#include<algorithm>
using namespace std;
int cmp(int a,int b){
	return a>b;
}
int gcd(int a,int b){

	if(a%b==0){
		return b;
	}else 
	return gcd(b,a%b);
}
int lcm(int a,int b){
	if(a==0&&b==0){
		return 0;
	}
	else if(a==0){
		return b;
	}else if(b==0){
		return a;
	}else return (a*b)/(gcd(a,b));
}

int main(){
	int n;
	int a[101];
	int res;
	while(scanf("%d",&n)!=EOF){
		for(int i=0;i<n;i++){
			 cin>>a[i];
		}
	
		sort(a,a+n,cmp);

		int c=a[0];
		for(int i=1;i<n;i++){
			c=lcm(c,a[i]);
		}
		cout<<c<<endl;
	}


    return 0;
}

**分析:这里注意__gcd函数会出现编译错误就自己手写。其次最好是让数组的数从大到小先进行排序,否则会出现错误 **

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡桃木子

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值