1147 Heaps (30分)-Heap、数组

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

解题思路:

  1. 完全二叉树并且为层次序列,采用数组表示更方便;
  2. 数组形式的二叉树的后序遍历。

AC代码:

#include <iostream>
#include <cmath>
using namespace std;
#define Max 1001
#define Inf 1E6+1
int heap[Max],IsCertain=0,flag=0,sign;
void posttravel(int i,int N);
void order(int i,int j);
int main(){
	int M,N,i;
	heap[0]=Inf;
	cin>>M>>N;
	while(M--){
		IsCertain=0;
		flag=0;
		for(i=1;i<=N;i++){
			scanf("%d",&heap[i]);
		}
		for(i=1;i<=N/2;i++){
			order(i,2*i);
			if(flag) break;
			if(2*i+1<=N)
				order(i,2*i+1);
			if(flag) break;
		}
		if(flag)
		printf("Not Heap\n");
	else{
		if(sign)
			printf("Max Heap\n");
		else
			printf("Min Heap\n");
		}
		posttravel(1,N);
	}	
	return 0;	
}
void posttravel(int i,int N){
	
	if(2*i<=N)
		posttravel(2*i,N);
	if(2*i+1<=N)
		posttravel(2*i+1,N);
	printf("%d",heap[i]);
	if(i>1)
		printf(" ");
	else
		printf("\n");	
}
void order(int i,int j){
	if(heap[i]!=heap[j]){
		if(heap[i]>heap[j]){
			if(IsCertain)
				flag=!sign;
			else{
				IsCertain=1;
				sign=1;
			}
					
		}
		else{
			if(IsCertain)
				flag=sign;
			else{
				IsCertain=1;
				sign=0;
			}
		}	
	}	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值