1147 Heaps(判断是否是堆)

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

堆首先满足完全二叉树的性质
本题题意:
     给定m个完全二叉树的n个结点值并放入数组tree中, 判断数组中的值 是 大顶堆, 小顶堆, 或者不是堆 最后后序遍历完全二叉树的结点值
本题思路:
    参考柳神的思路后:
    判断是否是堆时,首先定义一个flag = 0 ,当flag 为 0时就不是堆, 当flag 是 1 时 就是大顶堆,flag 为-1时就是小顶堆
    tree[0] > tree[1]时  用大顶堆判for断处理每个结点 当有节点不满足大顶堆的条件 就不是堆
    tree[0] <= tree[1]时 用小顶堆判for断处理每个结点 当有结点不满足小顶堆的条件 就不是堆
 
遇到的问题:
    不能将 right < n 单独放在左边判断 这样left <  
    eg :
    if(flag == 1 && right < n &&(tree[k] < tree[left] ||( tree[k] < tree[right] )))
    如果结点有4 个的情况,  第4个结点就不会判断
    正确的写法:
      单独判断左右
     (flag == 1 && (left < n && tree[k] < tree[left] ||( right < n && tree[k] < tree[right] )))

**/

#include<iostream>
#include<vector>
using namespace std;
int m, n;
vector<int> tree;
void postOrder(int index){ //先序遍历 
	if(index >= n) return;
	postOrder(index * 2 + 1);
	postOrder(index * 2 + 2);
	printf("%d%s", tree[index], index == 0 ? "\n" : " "); 
}
int flag;
int main(){
	scanf("%d%d", &m, &n);
	tree.resize(n);
	for(int i = 0;i < m; i++){
		for(int j = 0; j < n; j++){
			scanf("%d", &tree[j]);			
		}
		tree[0] > tree[1] ? flag = 1 : flag = -1; // 第一个结点大于第二个结点时,作大顶堆处理,否则作小顶堆处理 
		for(int k = 0; k <= (n - 1) / 2; k++){
			int left = k * 2 + 1, right = k * 2 + 2;
			if(flag == 1 && (left < n && tree[k] < tree[left] ||( right < n && tree[k] < tree[right] ))){ //处理时要保证下标不能越界 
				flag = 0;
				break;
			}
			if(flag == -1 && (left < n && tree[k] > tree[left] || (right < n && tree[k] > tree[right] ))){
				flag = 0;
				break;
			}
			
		}
		if(flag == 0)
			printf("Not Heap\n");
		else
			printf("%s\n", flag == -1 ? "Min Heap" : "Max Heap");
		postOrder(0);
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值