1143 Lowest Common Ancestor (30分)-前序和中序重构二叉树、LCA

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

解题思路:

将前序序列进行不降序排序,得到中序序列重构二叉树。

AC代码:

#include <iostream>
#include <malloc.h>
#include <set>
using namespace std;
#define Max 10000
typedef struct node* tree;
struct node{
	int data;
	tree left;
	tree right;
}; 
tree CreateTree(int* in,int sp1,int tp1,int* pre,int sp2,int tp2);
tree find(int a,int b,tree t);
int main(){
	int N,M,i;
	set<int> tr;
	int pre[Max],in[Max]; 
	cin>>M>>N;
	for(i=0;i<N;i++){
		scanf("%d",&pre[i]);
		tr.insert(pre[i]);
		}
	set<int>::iterator tt;
	for(tt=tr.begin(),i=0;tt!=tr.end();tt++,i++)
		in[i]=*tt;	
	tree t=NULL;
	if(N)
		t=CreateTree(in,0,N-1,pre,0,N-1);
	int a,b;
	for(i=0;i<M;i++){
		scanf("%d %d",&a,&b);
		int aIsFound=0,bIsFound=0;
		if(tr.find(a)!=tr.end())
			aIsFound=1;
		if(tr.find(b)!=tr.end())
			bIsFound=1;
		if(!aIsFound&&!bIsFound)
			printf("ERROR: %d and %d are not found.\n",a,b);
		else if(!aIsFound&&bIsFound)
			printf("ERROR: %d is not found.\n",a);
		else if(aIsFound&&!bIsFound)
			printf("ERROR: %d is not found.\n",b);
		else{
			tree k=find(a,b,t);
			if(k->data==a)
				printf("%d is an ancestor of %d.\n",a,b);
			else if(k->data==b)
				printf("%d is an ancestor of %d.\n",b,a);
			else
				printf("LCA of %d and %d is %d.\n",a,b,k->data);
		}		
	} 
	return 0;		
}
tree CreateTree(int* in,int sp1,int tp1,int* pre,int sp2,int tp2){
	tree head=(tree)malloc(sizeof(struct node));
	head->left=NULL;
	head->right=NULL;
    int i;
	if(tp1>sp1){
		for(i=sp1;i<=tp1;i++)
			if(in[i]==pre[sp2])
				break;		
		head->data=pre[sp2];
		if(i>sp1)
			head->left=CreateTree(in,sp1,i-1,pre,sp2+1,i+sp2-sp1);
		if(i<tp1)
			head->right=CreateTree(in,i+1,tp1,pre,i+sp2-sp1+1,tp2);	
	}
	else
		head->data=in[sp1];	
	return head;
}
tree find(int a,int b,tree t){
	if(t==NULL||t->data==a||t->data==b) return t;
	tree L=find(a,b,t->left);
	tree R=find(a,b,t->right);
	if(L!=NULL&R!=NULL) return t;
	if(!R) return L;
	return R;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值