1143 Lowest Common Ancestor

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目大意及思路

给出一棵BST的先序序列,求出树上任意两个结点的最近公共祖先LCA。
其实,由于该树是BST,那么任意两个结点a、b的LCA一定满足a <= LCA <= b,该树的先序序列已知,则LCA应是序列中第一个满足上述条件的结点。

AC代码

#include <cstdio>
#include <iostream>
#include <map> 
using namespace std;

map<int, int> mp; //某数是否在树上 
int pre[10010];

int main(){ 	
	int n, m;
	scanf("%d%d", &n, &m);
	for(int i = 0; i < m; i++){ 
		cin>>pre[i];
		mp[pre[i]] = 1;
	}
	int a, b;
	for(int i = 0; i < n; i++){
		scanf("%d%d", &a, &b);
		if(mp[a] == 0 && mp[b] == 1)
			printf("ERROR: %d is not found.\n", a);
		else if(mp[a] == 1 && mp[b] == 0)
			printf("ERROR: %d is not found.\n", b);
		else if(mp[a] == 0 && mp[b] == 0)
			printf("ERROR: %d and %d are not found.\n", a, b);
		else{	
			for(int j = 0; j < m; j++){
				if(pre[j] >= a && pre[j] <= b || pre[j] <= a && pre[j] >= b){
					if(pre[j] == b || pre[j] == a){
						if(pre[j] == b) swap(a, b); //大的为父亲
						printf("%d is an ancestor of %d.\n", a, b); 
					}		
					else printf("LCA of %d and %d is %d.\n", a, b, pre[j]);
					break;
				}
			}
		}
		
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值