1004 Counting Leaves (30分)-map、vector

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

解题思路:

  1. 树的表示:由于题目中树不是二叉树,因此需要其他形式来表示树。这里采用map和vector容器实现树的表示,map关键字为根结点ID,第二项为vector容器,存储子结点的ID。
  2. 统计每层叶结点数量:将根的ID压入一个层次向量中,last表示当前层次最后(最右边)一个结点,将last初值设为树的根;接下来读取层次向量中第一个元素,将它所有子结点压入层次中向量,如果没有子结点,计数器cnt加1。如果第一个元素等于last,则说明这一层结点统计完毕,cnt压入输出向量中,然后清零,将last重新赋值为层次向量中最后一个元素,即指向下一层次最后一个元素。当初向量第一个元素,此时向量非空,则继续循环。

AC代码:

#include <iostream>
#include <map>
#include <vector>
using namespace std;
int main(){
	int N,M,K,i;
	map<string,vector<string> >tree;
	vector<string> q;
	vector<int> ans;	
	cin>>N>>M;
	for(i=0;i<M;i++){
		string a,b;
		cin>>a>>K;
		while(K--){
			cin>>b;
			tree[a].push_back(b);
		}	
	}
	q.push_back("01");
	string last="01",now;
	int cnt=0,j;
	for(i=0;i<q.size();i++){
		for(j=0;j<tree[q[i]].size();j++){
			now=tree[q[i]][j];
			q.push_back(now);	
		}
		if(!j)
			cnt++;
		if(q[i]==last){
			last=now;
			ans.push_back(cnt);
			cnt=0;	
		}	
	}
	for(i=0;i<ans.size()-1;i++)
		printf("%d ",ans[i]);
	printf("%d",ans[i]);
	return 0;
}

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值