1057 Stack (30分)-堆栈、二分排序

该博客介绍了如何使用堆栈数据结构并添加额外的中位数查询功能。通过维护两个multiset,博主详细阐述了如何在插入和删除元素时保持中位数的正确性。示例输入和输出展示了算法的运行情况。
摘要由CSDN通过智能技术生成

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

解题思路:

题目大意是模拟一个堆栈,并添加返回中位数功能。

直接采用stack容器实现堆栈的压栈和弹栈功能,并用两个multiset(具有自动排序功能)容器s1,s2来保存中位数。设定中位数存储在s1的最后一位,s1要么比s2多一个元素,要么s1和s2元素相等,每当弹栈和压栈之后,都需要对s1和s2进行调整,如果s1元素小于s2,则将s2第一位元素移动至s1最后一位;如果s1的元素比s2多两个及以上,将s1的最后元素移动至s2首位。每次返回中位数时,直接返回s1的最后一位。

AC代码:

#include <iostream>
#include <set>
#include <stack>
using namespace std;
multiset<int> s1,s2;
stack<int> s;
int mid;
void adjust(){
	multiset<int>::iterator it;
	if(s1.size()<s2.size()){
		it=s2.begin();
		s1.insert(*it);
		s2.erase(s2.begin());	
	}
	else if(s1.size()>s2.size()+1){
		it=s1.end();
		it--;
		s2.insert(*it);
		s1.erase(it);
	}
	if(!s.empty()){
		it=s1.end();
		it--;
		mid=*it;
	}	
}
int main(){
	int N;
	cin>>N;
	char order[12];
	while(N--){
		scanf("%s",order);
		if(order[1]=='u'){
			int a;
			scanf("%d",&a);
			if(s.empty()||a<=mid)
				s1.insert(a);
			else
				s2.insert(a);
			s.push(a);	
			adjust();	
		}
		else if(order[1]=='o'){
			if(s.empty())
				printf("Invalid\n");
			else{
				printf("%d\n",s.top());
				if(s.top()<=mid)
					s1.erase(s1.find(s.top()));
				else
					s2.erase(s2.find(s.top()));
				s.pop();
				adjust();	
			}	
		}
		else{
			if(s.empty())
				printf("Invalid\n");
			else{
				multiset<int>::iterator it;
				it=s1.end();
				it--;
				printf("%d\n",*it);
			}
		}	
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值