PAT-A1057 Stack 题目内容及题解

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意

题目要求模拟一个栈,但是其中有一项特殊的要求:要求输出栈中元素的中值。当遇到出栈和查中值指令时输出结果或“Invalid”(无效操作)。

解题思路

由本题目的数据特点选用树状数组,树状数组的作用是查询任意两位之间的所有元素之和,但是每次只能修改一个元素的值;

每当有入栈操作时,所有相关位置更新+1,有出栈操作时,所有相关位置更新-1(计算中位数相关);

栈操作和输出结果时注意边界条件(栈操作相关);

按格式输出结果并返回零值。

代码

#include <stdio.h>
#define lowbit(i) ((i)&(-i))//i第一位1和其左边全部的0,能整除i的最大的i的幂次 
#define maxn 100010

int c[maxn];//树状数组 
//stack<int> s;
int s[maxn],top=-1;
 
void update(int x,int v){//更新操作,将第x个数加上一个数v 
    int i;
    for(i=x;i<maxn;i+=lowbit(i)){
        c[i]+=v;
    }
}
int getsum(int x){//返回前x个整数和 
    int sum=0,i;
    for(i=x;i>0;i-=lowbit(i)){
        sum+=c[i];
    }
    return sum;
}
void PeekMedian() {
    int left=1,right=maxn,mid,k=top/2+1;
    while(left<right) {
        mid=(left+right)/2;
        if(getsum(mid) >= k){
            right=mid;
        }else{
            left=mid+1;
        }
    }
    printf("%d\n",left);
}
int main(){
    int n,temp;
    int i;
    char str[15];
    scanf("%d", &n);
    for(i=0;i<n;i++) {
        scanf("%s",str);
        if(str[1]=='u') {
            scanf("%d", &temp);
            s[++top]=temp;
            update(temp,1);//位置temp+1
        }else if(str[1]=='o') {
            if(top>-1) {
                update(s[top],-1);
                printf("%d\n", s[top--]);
            } else {
                printf("Invalid\n");
            }
        }else{
            if(top>-1){
                PeekMedian();
            }else{
                printf("Invalid\n");
            }
        }
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值