PAT_(树的遍历)1004 Counting Leaves (30分) 1053 Path of Equal Weight (30分)

目录

1004 1004 Counting Leaves (30分) 

1053 Path of Equal Weight (30分)


 

1004 1004 Counting Leaves (30分) 

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf nodeK is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意:遍历树,计算每一层的叶子节点个数(root在第0层)bfs 计算每层节点数

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<cmath>
#define pb push_back 
using namespace std;
const int maxn=100005;
int n,m;
vector<int> tree[105];
int leaf[105];
int level;
void bfs(){
	queue<int> qu;
	qu.push(1);
	int tmp,len,cnt=0;
	while(!qu.empty()){
		len=qu.size();
		for(int i=0;i<len;i++){
			tmp=qu.front();qu.pop();
			if(!tree[tmp].size()){
				cnt++;
			}else{
				for(int j=0;j<tree[tmp].size();j++){
					qu.push(tree[tmp][j]);
				}	
			}	
		}
		leaf[level]=cnt;
		cnt=0;level++;
	}
}
int main(){
	scanf("%d%d",&n,&m);
	int node,k,tmp;
	for(int i=0;i<m;i++){
		scanf("%d%d",&node,&k);
		while(k--){
			scanf("%d",&tmp);
			tree[node].pb(tmp);
		}
	}
	bfs();
	for(int i=0;i<level;i++){
		if(i!=level-1)
		printf("%d ",leaf[i]);
		else printf("%d\n",leaf[i]);
	}
	
	return 0;		
}

 

1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

 

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number(权重和). 

The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​.

Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} 
if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意:给定一颗带权树,求所有从root到leaf的路径和=给定值 的路径,按照非递增的顺序输出;

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int target;
struct NODE {
    int w;
    vector<int> child;
};
vector<NODE> tree;
vector<int> path;
void dfs(int index, int nodeNum, int sum) {
    if(sum > target) return ;
    if(sum == target && !tree[index].child.size()) {
        for(int i = 0; i < nodeNum; i++)
            printf("%d%c", tree[path[i]].w, i != nodeNum - 1 ? ' ' : '\n');
        return ;
    }
    for(int i = 0; i < tree[index].child.size(); i++) {
        int node = tree[index].child[i];
        path[nodeNum] = node;
        dfs(node, nodeNum + 1, sum + tree[node].w);
    }
    
}
int cmp(int a, int b) {
    return tree[a].w > tree[b].w;
}
int main() {
    int n, m, node, k;
    scanf("%d %d %d", &n, &m, &target);
    tree.resize(n), path.resize(n);
    for(int i = 0; i < n; i++)
        scanf("%d", &tree[i].w);
    for(int i = 0; i < m; i++) {
        scanf("%d %d", &node, &k);
        tree[node].child.resize(k);
        for(int j = 0; j < k; j++)
            scanf("%d", &tree[node].child[j]);
        sort(tree[node].child.begin(), tree[node].child.end(), cmp);
    }
    dfs(0, 1, tree[0].w);
    return 0;
}

 

 

 

1004-2

#include<cstdio>
#include<cstring>
struct Node
{
	int father;
	int level;
	bool NoChild;
    Node(){
        father=0;level=0;NoChild=1;
    }
}v[100];
char level[100]="\0";       

int main()
{
	int N,M,i,j,c,ID,child,MAXLevel=1;
	scanf("%d%d",&N,&M);	
	for(i=0;i<M;++i){
		scanf("%d%d",&ID,&c);
		v[ID].NoChild=0;
		for(j=0;j<c;++j){
			scanf("%d",&child);
			v[child].father=ID;
		}
	}

	v[1].level=1;
	for(i=1;i<=N;++i)
		for(j=1;j<=N;++j)
		{
			if(v[j].father==i)
			{
				v[j].level=v[v[j].father].level+1;
				if(v[j].level>MAXLevel)
					MAXLevel=v[j].level;
			}
		}

	for(i=1;i<=N;++i)
		if(v[i].NoChild==1)
			level[v[i].level]++;
	for(i=1;i<MAXLevel;++i)
		printf("%d ",level[i]);
	printf("%d\n",level[i]);
	return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值