【C++OJ_静态与友元】最高成绩(静态成员)

【C++OJ_静态与友元】最高成绩(静态成员)

题目描述

学生类定义如下:

class Student {

private:

int id;//学号

int score; //成绩

static int maxscore;//最高分数

static int maxid;//最高分数学生学号

public:

Student(int ti=0,int ts=0)

:id(ti), score(ts)

{}

static void findMax(Student & st); //寻找最高成绩和学号

static int getMaxScore(); //返回最高成绩

static int getMaxID();//返回最高成绩的学号

};

输入一组学生学号和成绩,用上述静态成员求最高成绩和对应学号

输入

第一行输入n表示有n个学生

接着输入n行,每行包括两个数据,表示学号和成绩

输出

调用静态成员函数输出学号和最高成绩,格式看样例

输入样例

3
1002 68
1023 54
1045 32

输出样例

1002–68

参考代码

#include <iostream>
using namespace std;

class Student
{
private:
    int id;              //学号
    int score;           //成绩
    static int maxscore; //最高分数
    static int maxid;    //最高分数学生学号
public:
    Student(int ti = 0, int ts = 0) : id(ti), score(ts)
    {
    }
    static void findMax(Student &st); //寻找最高成绩和学号
    static int getMaxScore();         //返回最高成绩
    static int getMaxID();            //返回最高成绩的学号
};
int Student::maxscore = 0;
int Student::maxid = 0;
void Student::findMax(Student &st)
{
    if (st.score > Student::maxscore)
    {
        Student::maxscore = st.score;
        Student::maxid = st.id;
    }
}
int Student::getMaxScore()
{
    return Student::maxscore;
}
int Student::getMaxID()
{
    return Student::maxid;
}

int main()
{
    int t;
    cin >> t;
    while (t--)
    {
        int id;
        int sc;
        cin >> id >> sc;
        Student s(id, sc);
        Student::findMax(s);
    }
    cout << Student::getMaxID() << "--" << Student::getMaxScore() << endl;
    return 0;
}
  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ferry_xie

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值