string matching-上海交通大学研究生复试机试题

题目描述:
Time Limit: 1000 ms
Memory Limit: 256 mb
Finding all occurrences of a pattern in a text is a problem that arises frequently in text-editing programs. Typically,the text is a document being edited,and the pattern searched for is a particular word supplied by the user. We assume that the text is an array T[1…n] of length n and that the pattern is an array P[1…m] of length m<=n.We further assume that the elements of P and T are all alphabets(∑={a,b…,z}).The character arrays P and T are often called strings of characters. We say that pattern P occurs with shift s in the text T if 0<=s<=n and T[s+1…s+m] = P[1…m](that is if T[s+j]=P[j],for 1<=j<=m). If P occurs with shift s in T,then we call s a valid shift;otherwise,we calls a invalid shift. Your task is to calculate the number of vald shifts for the given text T and p attern P.
输入描述:
For each case, there are two strings T and P on a line,separated by a single space.You may assume both the length of T and P will not exceed 10^6.
输出描述:
You should output a number on a separate line,which indicates the number of valid shifts for the given text T and pattern P.
输入样例#
abababab abab
输出样例#:
3
题解代码如下

#include<bits/stdc++.h>
using namespace std;
const int P = 131,N = 1e6+7;
typedef unsigned long long ull;
ull h[N],p[N],pp;
char str[N],str1[N];
ull get(int l,int r){
	return h[r]-h[l-1]*p[r-l+1];
}
int main(){
	scanf("%s",str+1);
	scanf("%s",str1+1);
	p[0] = 1;
	int n = strlen(str+1);
	int m = strlen(str1+1);
	for(int i=1;i<=n;i++){
		p[i] = p[i-1]*P;
		h[i] = h[i-1]*P + str[i];
	}
	for(int i=1;i<=m;i++) pp = pp*P + str1[i];
	int ans = 0;
	for(int i=m;i<=n;i++){
		if(get(i-m+1,i)==pp) ans++;
	}
	printf("%d\n",ans);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值