Monthly Expense(POJ 3273)

问题描述:
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
输入:
Line 1: Two space-separated integers: N and M
Lines 2… N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
输出:
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
样例输入:
7 5
100
400
300
100
500
101
400
样例输出:
500

题目分析:
最大化最小值

无非是判断条件的选择而已,我选取mid, 是否需要M以上个分期,才使得每个分期的花费不大于d。如果条件为真的话,说明mid取得太小,二分搜索的下限太小了,那就把下限调大一点。否则根本不需要M个分期,说明mid太大,把上限调小一点。

#include<iostream>
#include<algorithm>
using namespace std;
int n,m;
const int maxn = 1000005;
int a[maxn];
inline bool judge(int x){
	int sum = 0;
	int cnt = 0;
	for(int i = 0;i<n;i++){
		if(sum+a[i]<=x)
		sum+=a[i];
		else{
			sum = a[i];
			cnt++;
		}
	} 
	return cnt>=m;
}

int main(){
	int l = -1,r = 0;
	int ans = 0;
	cin>>n>>m;
	for(int i = 0;i<n;i++){
		cin>>a[i];
		r+=a[i]; 
		l = max(l,a[i]);
	}
	while(l<=r){
		int mid = (l+r)>>1;
		if(judge(mid)){
			l = mid+1;
		}
		else{
			r = mid-1;
		}
	}
	cout<<l;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值