SDNUOJ——1062.Fibonacci(矩阵快速幂)

Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2.
Input
a single line containing n (where 0 ≤ n ≤ 100,000,000,000)
Output
print Fn mod 1000000007 in a single line.
Sample Input

99999999999

Sample Output

669753982

题:求斐波那契数列的第n项mod1000000007.。
之后,,它后面有个小提示:矩阵快速幂;
在这里插入图片描述
然后我就去借了一个模板过来A掉了

#include<stdio.h>
#include<iostream>
#include<map>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;
#define MAXN 100005
#define INF 0x3f3f3f3f//将近int类型最大数的一半,而且乘2不会爆int
#define MOD 1000000007

struct node
{
    ll a[2][2];
} stu;

node mulp(node x, node y)				//矩阵x*矩阵y
{
    node tem;
    memset(tem.a, 0, sizeof(tem.a));
    for(int i=0; i<2; ++i)
        for(int j=0; j<2; ++j)
            for(int k=0; k<2; ++k)
                tem.a[i][j]= (tem.a[i][j]+x.a[i][k]*y.a[k][j])%MOD;
    return tem;
}

ll qaq(node ans, ll b)
{
    stu.a[0][0] = stu.a[1][1] = 1;  //单位矩阵
    stu.a[0][1] = stu.a[1][0] = 0;
    while(b)
    {
        if(b&1)
            stu = mulp(stu, ans);
        ans = mulp(ans, ans);
        b >>= 1;
    }
    return stu.a[1][0];
}

int main()
{
    ll n;
    while(cin >>n)
    {
        node x = {1, 1, 1, 0};
        cout << qaq(x, n) << '\n';
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值