PAT甲 1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h    d
e    l
l     r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1​ characters, then left to right along the bottom line with n2​ characters, and finally bottom-up along the vertical line with n3​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1​=n3​=max { k | k≤n2​ for all 3≤n2​≤N } with n1​+n2​+n3​−2=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h      !
e     d
l       l
lowor

题目中的max我认为应该是k的意思,即n1=n3<n2。
由于共是三条边,所以我将输入字符串长度除以3得到余数,分为三种情况讨论,其中题目给的是10,11,通过样例可以易得出其式样,当输入的长度为9时,输出为:

1      9
2      8
34567

这种情况对应PAT中的测试数据的2和5。

#include<iostream>
#include<string>
using namespace std;

int main() {
	string str;
	int n,x=0,n1,n2;
	cin >> str;
	n = str.length();
	if (n % 3 == 0) {
		n1 = n / 3 -1;
		n2 = n / 3 +2;
	}
	else if (n % 3 == 1) {
		n1 = n / 3;
		n2 = n / 3 + 1;
	}
	else if (n % 3 == 2) {
		n1 = n / 3;
		n2 = n / 3 + 2;
	}

	for (int i = 0; i < n1; i++) {
		cout << str[i];
		for (int j = 0; j < n2-2; j++)
			cout << " ";
		cout<< str[n - i - 1] << endl;
	}
			
	for (int i = n1; i < n1+n2; i++)
		cout << str[i];

	return 0;
}

欢迎指导和交流!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值