PAT甲 1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

输出上需要注意如果输入数据为 4 0 00 000 1 输出应该为1。
测试点2的答案为0,所以程序加了最后一行,如果全是0的话,最后输出0,而不是不输出。
若直接使用sort的compare函数,比较前缀后,字符串长度长的为大,如32和321,321比32“大”,而实际上,321-32比32-321来的小,即321比32“小”。
自带的sort函数有出入,要自己写一个compare函数,其中当两个字符串A、B前缀相等时,组成两个新字符串,C=A+B D=B+A,再比较C和D的大小,此时C和D的长度相同,直接比较C和D的大小。

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

bool compare(string A, string B) {
	for (int i = 0; i < A.length() && i < B.length(); i++)
		if (A[i] < B[i]) return true;
		else if (A[i] > B[i]) return false;
	string C;
	string D;
	C = A + B;
	D = B + A;
	return C < D;
}

int main() {
	int n;
	string str[10001];
	cin >> n;
	for (int i = 0; i < n; i++)
		cin >> str[i];
	sort(str, str + n,compare);

	bool f = true;
	for (int i = 0; i < n; i++) {
		if (f == true) {
			for (int j = 0; j < str[i].length(); j++) {
				if (str[i][j] == '0' && f == true) continue;
				f = false;
				cout << str[i][j];
			}
		}
		else cout << str[i];
	}
	
	if (f == true) cout << "0";
	return 0;
}

欢迎指导和交流!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值