PAT甲级真题 1038 Recover the Smallest Number (30分)(自定义sort比较函数,比较拼接后的字符串)

题目

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Do not output leading zeros.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

思路

用字符串数组存储数字,自定义compare函数,将两个字符串分别前后组合,若s1+s2 < s2+s1,则将s1放到s2前面。

对整个数组排序后,将所有字符串连接成一个字符串(方便处理前面的0,因为前面可能有多个字符串均为0,如00 00 01),从第一个非’0’的位置输出即可。

注意不能简单按字典序排序,比如测试用例:
2 12 121
应输出:
12112

字符串比较的话是121 > 12,而正确答案应是121在前,12在后。

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

bool cmp(string &s1, string &s2){
    return s1+s2 < s2+s1;
}
int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);

    int n;
    cin >> n;
    vector<string> s(n);
    for (int i=0; i<n; i++){
        cin >> s[i];
    }

    sort(s.begin(), s.end(), cmp);

    string str = "";
    for (int i=0; i<n; i++){
        str += s[i];
    }
    int pos = 0;
    while (pos<str.size() && str[pos]=='0'){
        pos++;
    }
    if (pos==str.size())  {
        cout << "0";
    }
    while (pos<str.size()){
        cout << str[pos];
        pos++;
    }
    cout << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值