PAT甲 1060 Are They Equal (25 分)

该博客介绍了一个编程问题,涉及在机器上比较浮点数时由于精度限制导致的相等性判断。给定浮点数的有效位数,程序需要判断两个数在机器中是否被视为相等。示例输入和输出展示了比较过程,并提供了一个解决方案,通过结构体存储数字并进行比较。文章强调了处理0的指数和前导0的细节,并提供了测试数据。
摘要由CSDN通过智能技术生成

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.12010^3 0.12810^3

这个题大意很好理解,但是有很多坑点,比如所有0的指数都是0,即0.00……0*10^0,前缀0忽略等等。这推荐一个测试数据
https://blog.csdn.net/qq_39117553/article/details/104914126
我自己用一个结构体分别记录 去除前缀0的数 和指数,之后比较,得出结果。

#include<iostream>
#include<string>
#include<vector>
using namespace std;

struct Num {
	vector<int> ratio;
	int power;
};

Num n1, n2;
int n;

Num read() {
	string str;
	Num temp;
	cin >> str;
	int k = 0;
	temp.power = str.length();
	bool f = true;
	for (int i = 0; i < str.length(); i++) {
		if (str[i] == '.') {
			temp.power = k;
			continue;
		}
		else if (f == true && str[i] == '0') {
			temp.power--;
			continue;
		}
		if (str[i] != '0' || f == false) {
			k++;
			temp.ratio.push_back(str[i] - '0');
			f = false;
		}
	}
	if (f == true) temp.power = 0;
	if (temp.power < n) {
		for (int i = 0; i < n-temp.power; i++) {
			temp.ratio.push_back(0);
		}
	}
	return temp;
}

int main() {
	bool f = true;
	cin >> n;
	n1=read();
	n2=read();

	for (int i = 0; i < n; i++) {
		if (n1.ratio[i] != n2.ratio[i]) {
			f = false;
			break;
		}
	}
	if (n1.power != n2.power) f = false;

	if (f == true) {
		cout << "YES 0.";
		for (int i = 0; i < n; i++)
			cout << n1.ratio[i];
		cout << "*10^" << n1.power;
	}
	else {
		cout << "NO 0.";
		for (int i = 0; i < n; i++)
			cout << n1.ratio[i];
		cout << "*10^"<<n1.power<<" 0.";
		for (int i = 0; i < n; i++)
			cout << n2.ratio[i];
		cout << "*10^" << n2.power;
	}
	
	return 0;
}

欢迎指导和交流!

以下是对提供的参考资料的总结,按照要求结构化多个要点条输出: 4G/5G无线网络优化与网规案例析: NSA站点下终端掉4G问题:部用户反馈NSA终端频繁掉4G,主要因终端主动发起SCGfail导致。析显示,在信号较好的环境下,终端可能因节能、过热保护等原因主动释放连接。解决方案建议终端侧进行析处理,尝试关闭节电开关等。 RSSI算法识别天馈遮挡:通过计算RSSI平均值及差值识别天馈遮挡,差值大于3dB则认定有遮挡。不同设备组规则不同,如64T和32T。此方法可有效帮助现场人员识别因环境变化引起的网络问题。 5G 160M组网小区CA不生效:某5G站点开启100M+60M CA功能后,测试发现UE无法正常使用CA功能。问题原因在于CA频点集标识配置错误,修正后测试正常。 5G网络优化与策略: CCE映射方式优化:针对诺基亚站点覆盖农村区域,通过优化CCE资源映射方式(交织、非交织),提升RRC连接建立成功率和无线接通率。非交织方式相比交织方式有显著提升。 5G AAU两扇区组网:与三扇区组网相比,AAU两扇区组网在RSRP、SINR、下载速率和上传速率上表现不同,需根据具体场景选择适合的组网方式。 5G语音解决方案:包括沿用4G语音解决方案、EPS Fallback方案和VoNR方案。不同方案适用于不同的5G组网策略,如NSA和SA,并影响语音连续性和网络覆盖。 4G网络优化与资源利用: 4G室设备利旧:面对4G网络投资压减与资源需求矛盾,提出利旧多维度调优策略,包括资源整合、统筹调配既有资源,以满足新增需求和提质增效。 宏站RRU设备1托N射灯:针对5G深度覆盖需求,研究使用宏站AAU结合1托N射灯方案,快速便捷地开通5G站点,提升深度覆盖能力。 基站与流程管理: 爱立信LTE基站邻区添加流程:未提供具体内容,但通常涉及邻区规划、参数配置、测试验证等步骤,以确保基站间顺畅切换和覆盖连续性。 网络规划与策略: 新高铁跨海大桥覆盖方案试点:虽未提供详细内容,但可推测涉及高铁跨海大桥区域的4G/5G网络覆盖规划,需考虑信号穿透、移动性管理、网络容量等因素。 总结: 提供的参考资料涵盖了4G/5G无线网络优化、网规案例析、网络优化策略、资源利用、基站管理等多个方面。 通过具体案例析,展示了无线网络优化中的常见问题及解决方案,如NSA终端掉4G、RSSI识别天馈遮挡、CA不生效等。 强调了5G网络优化与策略的重要性,包括CCE映射方式优化、5G语音解决方案、AAU扇区组网选择等。 提出了4G网络优化与资源利用的策略,如室设备利旧、宏站RRU设备1托N射灯等。 基站与流程管理方面,提到了爱立信LTE基站邻区添加流程,但未给出具体细节。 新高铁跨海大桥覆盖方案试点展示了特殊场景下的网络规划需求。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值