Python安装第三方包报错:InsecurePlatformWarning: A true SSLContext object is not available.

# 执行pip install dataset报错如下
InsecurePlatformWarning: A true SSLContext object is not available. 
This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. 
For more information,see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
InsecurePlatformWarning

解决方法
因为SSL的问题,urllib3需要pyopenssl。

pip install pyopenssl ndg-httpsclient pyasn1

还需要安装libffi-dev,libssl-dev
1.Ubuntu下安装

sudo apt-get install libffi-dev libssl-dev

2.CentOS下安装

yum install libffi-devel openssl-devel
发布了14 篇原创文章 · 获赞 11 · 访问量 2万+
展开阅读全文

SNIMissingWarning + InsecurePlatformWarning

08-19

用pip安装一些包时遇到 SNIMissingWarning + InsecurePlatformWarning (unbuntu 12.04.5/python 2.7.3/pip 9.0.1) 具体细节如下,请高手指点,多谢! aiboat@ubuntu:/usr/local/bin$ sudo -H pip install pyopenssl ndg-httpsclient pyasn1 --upgrade /usr/local/lib/python2.7/dist-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#snimissingwarning. SNIMissingWarning /usr/local/lib/python2.7/dist-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:122: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/security.html#insecureplatformwarning. InsecurePlatformWarning Requirement already up-to-date: pyopenssl in /usr/local/lib/python2.7/dist-packages Requirement already up-to-date: ndg-httpsclient in /usr/local/lib/python2.7/dist-packages Requirement already up-to-date: pyasn1 in /usr/local/lib/python2.7/dist-packages Requirement already up-to-date: cryptography>=1.9 in /usr/local/lib/python2.7/dist-packages (from pyopenssl) Requirement already up-to-date: six>=1.5.2 in /usr/local/lib/python2.7/dist-packages (from pyopenssl) Requirement already up-to-date: asn1crypto>=0.21.0 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.9->pyopenssl) Requirement already up-to-date: cffi>=1.7 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.9->pyopenssl) Requirement already up-to-date: ipaddress in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.9->pyopenssl) Requirement already up-to-date: enum34 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.9->pyopenssl) Requirement already up-to-date: idna>=2.1 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.9->pyopenssl) Requirement already up-to-date: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.7->cryptography>=1.9->pyopenssl) 问答

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 技术工厂 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览