POJ 2533 单调递增最长子序列

POJ2533

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 42914 Accepted: 18914
Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input
7 
1 7 3 5 9 4 8 
Sample Output
4

思路:

跟上一篇博客一样,
题目的大意是:给出一序列,求出该序列的最长上升子序列的最大长度。
思路:用数组s[]存储序列,dp[i]表示以s[i]为结尾的序列的最大长度。
因此要求出dp[i]的最大值,即求出max{dp[0],dp[1]…dp[i-1]}的最大值,那么dp[i]的最大值为max{dp[0],dp[1]…dp[i-1]}+1;
即可写出状态方程:dp[i]=max{dp[0],dp[1]…dp[j]}+1;(0<=j<i&&s[j]<s[i]),然后求出数组dp[]中的最大值即为所求(每次用ans记录就行了)

状态转移方程: if(s[j]<s[i]) dp[i]=max(dp[i],dp[j]+1);

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAXN=1005;
int main()
{
    int s[MAXN],dp[MAXN];
    int len;
    cin>>len;
    int ans=0;
    for(int i=0;i<len;i++)
    {
        cin>>s[i];
        dp[i]=1;
        for(int j=0;j<i;j++)
        {
            if(s[j]<s[i])
                dp[i]=max(dp[i],dp[j]+1);
        }
        ans=max(ans,dp[i]);     //把ans放在上边这个for循环外边就过了。。。。。。卡时间???好叭。。
    }
    cout<<ans;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值