PAT甲级1023 Have Fun with Number

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

翻译:请注意,数字123456789是一个9位数的数字,完全由1到9组成,没有重复。给它加倍之后我们将得到246913578,它恰好是另一个9位数的数字,正好包含从1到9的数字,只是排列不同。如果我们再加倍看看结果!
现在,假设您要检查是否有更多具有此属性的数字。也就是说,给一个有k位数字的数加倍,你要知道结果数字是否只由原始数字中的数字排列组成。

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路

这题很简单,就是普通的大数乘法模拟,要注意的是:不是判断加倍前的每位数是否在加倍后的数中出现过,而是判断是否由加倍前的每一位数组成的。也就是说要统计数的个数(可能只有我一个人理解错题意了,不过也只有测试点4出错)正确理解题意之后这题就满分AC

#include <iostream>
#include <cstdlib>
#include <string>
using namespace std;
string get_double(string);
int str1[10] = {0}; //记录加倍前的每位数出现的频数
int str2[10] = {0}; //记录加倍后的每位数出现的频数
int main()
{
	string str;
	cin >> str;
	for (int i = 0; i < str.size(); i++)
		str1[str[i] - '0']++; //统计频数
	string d_str = get_double(str);
	for (int i = 0; i < d_str.size(); i++)
		str2[d_str[i] - '0']++;
	int flag = 0;
	for (int i = 0; i < 10; i++)
	{
		if (str1[i] != str2[i])
		{
			flag = 1;
			break;
		}
	}
	if (!flag)
		cout << "Yes" << endl;
	else
		cout << "No" << endl;
	cout << d_str << endl;
	system("pause");
	return 0;
}
string get_double(string s) //模拟大数乘法
{
	string ans;
	int carry = 0;
	for (int i = s.size() - 1; i >= 0; i--)
	{
		int d = (s[i] - '0') * 2 + carry;
		carry = d / 10;
		d %= 10;
		ans = to_string((long long)d) + ans;
	}
	if (carry != 0)
		ans = "1" + ans;
	return ans;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值