PAT甲级1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​​ −grade​M​​ . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

思路

很简单的题目,不需要用排序也能做,就是每次输入的时候都作比较,存储最低分的男生和最高分的女生,最后按要求输出即可

#include <iostream>
#include <cstdlib>
#include <string>
#include <vector>
#include <algorithm>
#include <climits>
using namespace std;
int main()
{
	string low_boy, high_girl, boy_sub, girl_sub;
	int lowest = INT_MAX, highest = -1;
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		string name, gender, subject;
		int grade;
		cin >> name >> gender >> subject >> grade;
		if (gender == "F")
		{
			if (grade > highest)
			{
				highest = grade;
				girl_sub = subject;
				high_girl = name;
			}
		}else
		{
			if (grade < lowest)
			{
				lowest = grade;
				boy_sub = subject;
				low_boy = name;
			}
		}
	}
	bool flag = 0;
	if (highest != -1)
		cout << high_girl << ' ' << girl_sub << endl;
	else
	{
		flag = 1;
		cout << "Absent\n";
	}
	if (lowest != INT_MAX)
		cout << low_boy << ' ' << boy_sub << endl;
	else
	{
		flag = 1;
		cout << "Absent\n";
	}
	if (flag)
		cout << "NA\n";
	else
		cout << highest - lowest << endl;
	system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值