PAT甲级1037 Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC​​ , followed by a line with NC​​ coupon integers. Then the next line contains the number of products NP​​ , followed by a line with NP​​ product values. Here 1≤NC​​ ,NP​ ≤105​​ , and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目大意

给出两个集合,从这两个集合中分别选取相同数量的元素进行一对一相乘,问能得到的乘积之和最大是多少

思路

能想到用贪心算法,但是我实现起来的方法很笨。既然要最大的,我就让两个正数最大的相乘,两个负数最小(负数小,绝对值大)的相乘。用了四个数组,分别记录正优惠券,负优惠券,正产品价格,负产品价格。然后正优惠券和正产品从大到小排序;负优惠券,负产品从小到大排序。分别遍历相乘最后相加。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
bool cmp(int a, int b) { return a > b; };
int main()
{
	vector<int> pcoup; //正优惠券
	vector<int> ncoup; //负优惠券
	int nc;
	cin >> nc;
	for (int i = 0; i < nc; i++)
	{
		int cou;
		cin >> cou;
		if (cou > 0)
			pcoup.push_back(cou);
		else
			ncoup.push_back(cou);
	}
	vector<int> pprod; //正产品价格
	vector<int> nprod; //负产品价格
	int np;
	cin >> np;
	for (int i = 0; i < np; i++)
	{
		int pro;
		cin >> pro;
		if (pro > 0)
			pprod.push_back(pro);
		else
			nprod.push_back(pro);
	}
	sort(pcoup.begin(), pcoup.end(), cmp);
	sort(pprod.begin(), pprod.end(), cmp);
	sort(ncoup.begin(), ncoup.end());
	sort(nprod.begin(), nprod.end());
	int ans = 0;
	int size1 = pcoup.size() > pprod.size() ? pprod.size() : pcoup.size();
	int size2 = ncoup.size() > nprod.size() ? nprod.size() : ncoup.size();
	for (int i = 0; i < size1; i++)
		ans += pcoup[i] * pprod[i];
	for (int i = 0; i < size2; i++)
		ans += ncoup[i] * nprod[i];
	cout << ans << endl;
	system("pause");
	return 0;
}

coupon 优惠券

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值