Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.
Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.
Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
思路
题目不难,但是用平常的string做法处理和cin、cout的输出会导致超时,所以最好还是用char数组的方法,输入输出用scanf,printf
最后一个测试点超时的做法
#include <iostream>
#include <cstdlib>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
using namespace std;
int main()
{
map<int, vector<string> > mp;
int n, k;
cin >> n >> k;
for (int i = 0; i < n; i++)
{
int num;
string name;
cin >> name >> num;
for (int j = 0; j < num; j++)
{
int course;
cin >> course;
mp[course].push_back(name);
}
}
for (int i = 0; i < k; i++)
{
cout << i + 1 << ' ' << mp[i + 1].size() << endl;
sort(mp[i + 1].begin(), mp[i + 1].end());
for (int j = 0; j < mp[i + 1].size(); j++)
cout << mp[i + 1][j] << endl;
}
system("pause");
return 0;
}
满分做法
#include <iostream>
#include <cstdlib>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
char name[40001][5];
vector<int> course[2501];
bool cmp(int a, int b) { return strcmp(name[a], name[b]) < 0; }
int main()
{
int n, k;
cin >> n >> k;
for (int i = 0; i < n; i++)
{
int num;
cin >> name[i] >> num;
//数字i对应一个学生名字
for (int j = 0; j < num; j++)
{
int c;
cin >> c;
course[c].push_back(i); //将选课程c的学生i列入数组
}
}
for (int i = 1; i <= k; i++)
{
cout << i << " " << course[i].size() << endl;
sort(course[i].begin(), course[i].end(), cmp);
for (int j = 0; j < course[i].size(); j++)
printf("%s\n", name[course[i][j]]);
}
system("pause");
return 0;
}