PAT甲级1057 Stack//分块思想应用

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤105​​ ). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop

PeekMedian
where key is a positive integer no more than 10​5.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

题目大意

题目意思就是给普通的栈添加一个输出中值的功能,注意不是中间的值而是数值从小到大中,中间的那个值。但是这里用排序会超时。然后学习了算法笔记中的分块思想方法,先看这里理解方法分块思想

#include <iostream>
#include <vector>
#include <cstdlib>
#include <string>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std;
int table[100001] = {0};
int block[317] = {0};
int main()
{
	int num;
	vector<int> stk;
	cin >> num;
	getchar();
	for (int i = 0; i < num; i++)
	{
		string cmd;
		getline(cin, cmd);
		if (cmd == "Pop")
		{
			if (stk.size() == 0)
				cout << "Invalid" << endl;
			else
			{
				int num = stk[stk.size() - 1];
				cout << num << endl;
				stk.pop_back();
				block[num / 316]--;
				table[num]--;
			}
		}
		else if (cmd[1] == 'u')
		{
			int n = stoi(cmd.substr(5));
			stk.push_back(n);
			block[n / 316]++;
			table[n]++;
		}
		else
		{
			if (stk.size() == 0)
				cout << "Invalid" << endl;
			else
			{
				int K = (stk.size() % 2 == 0) ? stk.size() / 2 : ((stk.size() + 1) / 2), sum = 0, j = 0;
				for (j = 0; j < 317; j++)
				{
					if (sum + block[j] >= K)
						break;
					else
						sum += block[j];
				}
				int p = 0;
				for (p = j * 316; p <= p + 315; p++)
				{
					if (sum + table[p] >= K)
						break;
					else
						sum += table[p];
				}
				cout << p << endl;
			}
		}
	}
	system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值