PAT甲级1078 Hashing//模拟散列表冲突解决方法----平方探查法

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

思路

这里的Quadratic probing就是平方探查的意思,就是当Hash(a)发生冲突时,让a按照a + 12、a - 12、a + 22、a - 22…的顺序调整a的值。而题目中说明with positive increments only,意思是只往正向增加来解决冲突。
大致思路就是输入一个数之后把他归进散列表,如果发生冲突则执行平方探查法,公式是posion = (a + step * step) % TSize,如果还是冲突,继续执行直到不发生冲突。注意这里step从1枚举到TSize - 1就行(枚举到TSize的话,按照公式(a + TSize * TSize) % TSize的结果还是回到了a本身),如果到了TSize还是冲突,就输出-

#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;
int table[10005];
bool isprime(int);
int find_prime(int);
int main()
{
	int Msize, n;
	cin >> Msize >> n;
	vector<int> vec;
	for (int i = 0; i < n; i++)
	{
		int num;
		cin >> num;
		vec.push_back(num);
	}
	int Tsize = find_prime(Msize);
/*	while (isprime(Tsize) == false)
		Tsize++;      用这个方法求Tsize更好  */
	for (int i = 0; i < n; i++)
	{
		if (i > 0)
			cout << " ";
		if (table[vec[i] % Tsize] == 0)
		{
			table[vec[i] % Tsize] = vec[i];
			cout << vec[i] % Tsize;
		}
		else //发生冲突
		{
			int step;
			for (step = 1; step < Tsize; step++)
			{
				int index = (vec[i] + step * step) % Tsize;
				if (table[index] == 0)
				{
					table[index] = vec[i];
					cout << index;
					break; //不冲突就退出循环
				}
			}
			if (step >= Tsize) //step到了TSize大小还是冲突,就输出-
				cout << "-";
		}
	}
	system("pause");
	return 0;
}
bool isprime(int n)
{
	if (n < 2)
		return false;
	else
	{
		for (int i = 2; i * i <= n; i++)
			if (n % i == 0)
				return false;
	}
	return true;
}
int find_prime(int n)
{
	int i = n;
	for (; i <= 100000; i++) //这里刚开始写i <= 10005测试点2、3会出错
		if (isprime(i))
			break;
	return i;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值