PAT甲级1105 Spiral Matrix

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104​​ . The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

思路

时隔一年又做了一遍螺旋矩阵,感觉这题比较考验对下标的运用。详细题解看这里。同时补充一点,不要忘记内部for循环里的index < n的条件,因为比如给3个数,将会是三行一列的矩阵,这时候内部的4个for循环只有前三个起作用,这时如果没有这个条件将会发生数组越界。

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
bool cmp(int a, int b) { return a > b; }
int main()
{
	int n;
	cin >> n;
	vector<int> vec;
	for (int i = 0; i < n; i++)
	{
		int num;
		cin >> num;
		vec.push_back(num);
	}
	sort(vec.begin(), vec.end(), cmp);
	int col = (int)sqrt(n);
	while (n % col)
		col--;
	int row = n / col;
	vector<vector<int> > matrix;
	for (int i = 0; i < row; i++)
	{
		vector<int> v(col);
		matrix.push_back(v);
	}
	int times = row % 2 ? (row / 2) + 1 : row / 2;
	int index = 0;
	for (int i = 0; i < times; i++)
	{
		for (int j = i; j < col - i && index < n; j++)
			matrix[i][j] = vec[index++];
		for (int j = i + 1; j < row - i - 1 && index < n; j++)
			matrix[j][col - i - 1] = vec[index++];
		for (int j = col - i - 1; j >= i && index < n; j--)
			matrix[row - i - 1][j] = vec[index++];
		for (int j = row - i - 2; j >= i + 1 && index < n; j--)
			matrix[j][i] = vec[index++];
	}
	for (int i = 0; i < row; i++)
	{
		for (int j = 0; j < col; j++)
		{
			if (j != 0)
				cout << " ";
			cout << matrix[i][j];
		}
		cout << endl;
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值