PAT甲级1154 Vertex Coloring//图结点着色问题

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题目大意

题目要求一个图中任意一条边上的两个端点颜色不能相同。现在给出一个图,再给出每个点的颜色,判断一条边上的两个端点颜色是否相同,如果出现相同的输出No,如果都不相同,输出整个图一共有几种颜色。

#include <iostream>
#include <cstdlib>
#include <map>
#include <vector>
using namespace std;
struct node
{
	int beg;
	int end;
};
int main()
{
	int N, M;
	cin >> N >> M;
	vector<node> edg;
	for (int i = 0; i < M; i++)
	{
		node s;
		cin >> s.beg >> s.end; //记录每条边的端点
		edg.push_back(s);
	}
	int K;
	map<int, bool> clr;
	vector<int> color(N);
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		for (int j = 0; j < N; j++)
		{
			cin >> color[j]; //记录每个结点的颜色
			clr[color[j]] = true;
		}
		bool flag = false;
		for (int j = 0; j < M; j++)
		{
			int beg = edg[j].beg, end = edg[j].end;
			if (color[beg] == color[end]) //如果出现一条边上两个端点颜色相同则输出No
			{
				flag = true;
				break;
			}
		}
		if (flag)
			cout << "No" << endl;
		else
			cout << clr.size() << "-coloring" << endl;
		clr.clear();
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值